New User Approve <= 2.5.1 - Cross-Site Request Forgery via admin_notices

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-50902
CVSS 6.1 (Medium)
Publicly Published December 26, 2023
Last Updated January 22, 2024
Researcher RE-ALTER


The New User Approve plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.5.2. This is due to missing or incorrect nonce validation on the admin_notices function. This makes it possible for unauthenticated attackers to dismiss admin notices via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for New User Approve

Software Type Plugin
Software Slug new-user-approve (view on
Patched? Yes
Remediation Update to version 2.5.2, or a newer patched version
Affected Version
  • <= 2.5.1
Patched Version
  • 2.5.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.