Newsletter - API v1 and v2 addon for Newsletter <= 2.4.5 - Missing Authorization to Email Subscribers Management

Missing Authorization
CVE CVE-2024-5674
CVSS 6.5 (Medium)
Publicly Published June 11, 2024
Last Updated June 12, 2024
Researcher Arkadiusz Hydzik


The Newsletter - API v1 and v2 addon plugin for WordPress is vulnerable to unauthorized subscribers management due to PHP type juggling issue on the check_api_key function in all versions up to, and including, 2.4.5. This makes it possible for unauthenticated attackers to list, create or delete newsletter subscribers. This issue affects only sites running the PHP version below 8.0



Vulnerability Details for Newsletter - API v1 and v2 addon for Newsletter

Software Type Plugin
Software Slug newsletter-api
Patched? Yes
Remediation Update to version 2.4.6, or a newer patched version
Affected Version
  • <= 2.4.5
Patched Version
  • 2.4.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.