Newsletter <= 8.0.6 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVSS 4.7 (Medium)
Publicly Published January 10, 2024
Last Updated January 10, 2024


The Newsletter – Send awesome emails from WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 8.0.6. This is due to missing or incorrect nonce validation in the main/welcome.php file. This makes it possible for unauthenticated attackers to modify the plugin's settings and send test emails via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Newsletter – Send awesome emails from WordPress

Software Type Plugin
Software Slug newsletter (view on
Patched? Yes
Remediation Update to version 8.0.7, or a newer patched version
Affected Version
  • <= 8.0.6
Patched Version
  • 8.0.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.