Newsletter Lite <= 4.9.2 - Authenticated (Admin+) Command Injection

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')
CVE CVE-2023-4797
CVSS 6.6 (Medium)
Publicly Published October 5, 2023
Last Updated February 7, 2024
Researcher Karolis Narvilas


The Newsletters plugin for WordPress is vulnerable to Command Injection in all versions up to, and including, 4.9.2 via the emailarchive_olderthan parameter. This is due to insuffcient validation on user supplied input being passed to eval. This makes it possible for authenticated attackers, with administrator-level access and above, to execute code on the server.



Vulnerability Details for Newsletters

Software Type Plugin
Software Slug newsletters-lite (view on
Patched? Yes
Remediation Update to version 4.9.3, or a newer patched version
Affected Version
  • <= 4.9.2
Patched Version
  • 4.9.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.