Newsletters <= 4.6.18 - Cross-Site Scripting via contentarea Parameter

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2019-14787
CVSS 5.4 (Medium)
Publicly Published July 1, 2019
Last Updated January 8, 2023


The Tribulant Newsletters plugin before 4.6.19 for WordPress allows XSS via the wp-admin/admin-ajax.php?action=newsletters_load_new_editor contentarea parameter.



Vulnerability Details for Newsletters

Software Type Plugin
Software Slug newsletters-lite (view on
Patched? Yes
Remediation Update to version 4.6.19, or a newer patched version
Affected Version
  • < 4.6.19
Patched Version
  • 4.6.19

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.