Newsletters <= 4.8.8 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-30478
CVSS 5.4 (Medium)
Publicly Published April 13, 2023
Last Updated April 11, 2024
Researcher Rio Darmawan - Zerobyte


The Newsletters plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.8.8. This is due to missing nonce validation on several cases in several functions like admin_groups() and admin_forms(). This makes it possible for unauthenticated attackers to manipulate forms and groups via a forged request, granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Newsletters

Software Type Plugin
Software Slug newsletters-lite (view on
Patched? Yes
Remediation Update to version 4.8.9, or a newer patched version
Affected Version
  • <= 4.8.8
Patched Version
  • 4.8.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.