NEX-Forms <= 7.7.1 - Missing Authorization on Various AJAX Actions

Missing Authorization
CVE CVE-2020-36670
CVSS 6.3 (Medium)
Publicly Published November 27, 2020
Last Updated March 7, 2023
Researcher Chloe Chamberland


The NEX-Forms. plugin for WordPress is vulnerable to unauthorized disclosure and modification of data in versions up to, and including 7.7.1 due to missing capability checks on several AJAX actions. This makes it possible for authenticated attackers with subscriber level permissions and above to invoke these functions which can be used to perform actions like modify form submission records, deleting files, sending test emails, modifying plugin settings, and more.

Wordfence blocked 2 attacks targeting this vulnerability in the past 24 hours.



1 affected software package

Software Type Plugin
Software Slug nex-forms-express-wp-form-builder (view on
Patched? Yes
Remediation Update to version 7.8, or a newer patched version
Affected Version
  • <= 7.7.1
Patched Version
  • 7.8

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.