NextGen Gallery <= 2.1.9 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2015-9537
CVSS 6.4 (Medium)
Publicly Published August 31, 2015
Last Updated February 2, 2023
Researcher Sathish Kumar


The NextGEN Gallery plugin before 2.1.10 for WordPress has multiple XSS issues involving thumbnail_width, thumbnail_height, thumbwidth, thumbheight, wmXpos, and wmYpos, and template.



Vulnerability Details for Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery

Software Type Plugin
Software Slug nextgen-gallery (view on
Patched? Yes
Remediation Update to version 2.1.10, or a newer patched version
Affected Version
  • <= 2.1.9
Patched Version
  • 2.1.10

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.