NextGen Gallery <= 3.1.5 - PHP Object Injection

Deserialization of Untrusted Data
CVSS 8.8 (High)
Publicly Published February 4, 2019
Last Updated February 2, 2023
Researcher Slavco Mihajloski


The NextGen Gallery plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 3.1.5. This is due to the plugin unserializing serialized data obtained via user supplied input from the `sortorder` parameter. This makes it possible for authenticated attackers to call arbitrary PHP Objects and achieve remote code execution when the right gadgets are available.



Vulnerability Details for Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery

Software Type Plugin
Software Slug nextgen-gallery (view on
Patched? Yes
Remediation Update to version 3.1.6, or a newer patched version
Affected Version
  • <= 3.1.5
Patched Version
  • 3.1.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.