WordPress Gallery Plugin – NextGEN Gallery <= 2.1.15 - Authenticated (Admin+) Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2015-9229
CVSS 5.5 (Medium)
Publicly Published September 14, 2015
Last Updated January 22, 2024
Researcher cybersecurityworks


In the nggallery-manage-gallery page in the Photocrati NextGEN Gallery plugin 2.1.15 for WordPress, XSS is possible for remote authenticated administrators via the images[1][alttext] parameter.



Vulnerability Details for Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery

Software Type Plugin
Software Slug nextgen-gallery (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.23, or a newer patched version
Affected Version
  • <= 2.1.15
Patched Version
  • 2.1.23

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.