WordPress Gallery Plugin – NextGEN Gallery <= 3.59 - Missing Authorization to Unauthenticated Information Disclosure

Missing Authorization
CVE CVE-2024-3097
CVSS 5.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 9, 2024
Researcher Peng Zhou


The WordPress Gallery Plugin – NextGEN Gallery plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the get_item function in versions up to, and including, 3.59. This makes it possible for unauthenticated attackers to extract sensitive data including EXIF and other metadata of any image uploaded through the plugin.



Vulnerability Details for Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery

Software Type Plugin
Software Slug nextgen-gallery (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.59.1, or a newer patched version
Affected Version
  • <= 3.59
Patched Version
  • 3.59.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.