Ninja Forms <= 3.6.25 - Denial of Service via Large Form Submissions

5.3
Uncontrolled Resource Consumption ('Resource Exhaustion')
CVE CVE-2023-35909
CVSS 5.3 (Medium)
Publicly Published July 7, 2023
Last Updated January 22, 2024
Researcher PetiteMais

Description

The Ninja Forms plugin for WordPress is vulnerable to denial of service in versions up to, and including, 3.6.25. This is due to insufficient controls on form submissions. This makes it possible for unauthenticated attackers to craft form submissions with excessive extra data that may exceed the capacity of the database and prevent further requests from being successful while the submission is processing.

References

Share

Vulnerability Details for Ninja Forms – The Contact Form Builder That Grows With You

Software Type Plugin
Software Slug ninja-forms (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.6.26, or a newer patched version
Affected Version
  • <= 3.6.25
Patched Version
  • 3.6.26

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation