GDPR CCPA Compliance & Cookie Consent Banner <= 2.7.0 - Missing Authorization to Settings Update and Stored Cross-Site Scripting

Missing Authorization
CVE CVE-2024-5607
CVSS 5.4 (Medium)
Publicly Published June 6, 2024
Last Updated June 7, 2024
Researcher Lucio Sá


The GDPR CCPA Compliance & Cookie Consent Banner plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several functions named ajaxUpdateSettings() in all versions up to, and including, 2.7.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify the plugin's settings, update page content, send arbitrary emails and inject malicious web scripts.



Vulnerability Details for GDPR CCPA Compliance & Cookie Consent Banner

Software Type Plugin
Software Slug ninja-gdpr-compliance (view on
Patched? Yes
Remediation Update to version 2.7.1, or a newer patched version
Affected Version
  • <= 2.7.0
Patched Version
  • 2.7.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.