Frontend File Manager Plugin <= 21.2 - Cross-Site Request Forgery to File Upload

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-3126
CVSS 8.8 (High)
Publicly Published September 26, 2022
Last Updated January 22, 2024
Researcher Raad Haddad


The "Frontend File Manager Plugin" plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 21.2. This is due to missing or incorrect nonce validation on the wpfm_upload_file function. This makes it possible for unauthenticated attackers to upload files on behalf of other users, via forged request granted they can trick such a user into performing an action such as clicking on a link.



Vulnerability Details for Frontend File Manager Plugin

Software Type Plugin
Software Slug nmedia-user-file-uploader (view on
Patched? Yes
Remediation Update to version 21.3, or a newer patched version
Affected Version
  • <= 21.2
Patched Version
  • 21.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.