WP OAuth Server <= 4.2.5 - Authenticated (Subscriber+) Arbitrary Client Deletion (wo_ajax_remove_client)

Incorrect Authorization
CVE CVE-2022-4148
CVSS 4.3 (Medium)
Publicly Published February 21, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The WP OAuth Server plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the wo_ajax_remove_client() function in versions up to, and including, 4.2.5. This makes it possible for authenticated attackers with minimal permissions such as a subscriber to delete arbitrary clients.



Vulnerability Details for WP OAuth Server (OAuth Authentication)

Software Type Plugin
Software Slug oauth2-provider (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.3.0, or a newer patched version
Affected Version
  • <= 4.2.5
Patched Version
  • 4.3.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.