Ocean Extra <= 2.1.2 - Authenticated (Subscriber+) Arbitrary Post Access

Authorization Bypass Through User-Controlled Key
CVE CVE-2023-0749
CVSS 6.5 (Medium)
Publicly Published February 14, 2023
Last Updated February 14, 2023
Researcher Erwan LR - WPScan


The Ocean Extra for WordPress is vulnerable to disclosure of potentially sensitive data in versions up to, and including, 2.1.2. This is due to to the [oceanwp_library] shortcode not properly validating a post's status prior to returning the post's content. This makes it possible for authenticated attackers with subscriber-level permissions and above to retrieve arbitrary post content, even when it is in a pre-published or private status.



1 affected software package

Software Type Plugin
Software Slug ocean-extra (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.3, or a newer patched version
Affected Version
  • <= 2.1.2
Patched Version
  • 2.1.3

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.