MailerLite – Signup forms <= 1.4.4 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVSS 5.4 (Medium)
Publicly Published May 22, 2020
Last Updated January 22, 2024
Researcher Patchstack


The MailerLite – Signup forms plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.4.4. This is due to missing or incorrect nonce validation on multiple functions. This makes it possible for unauthenticated attackers to create, modify, or delete signup forms via forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for MailerLite – Signup forms (official)

Software Type Plugin
Software Slug official-mailerlite-sign-up-forms (view on
Patched? Yes
Remediation Update to version 1.4.5, or a newer patched version
Affected Version
  • < 1.4.5
Patched Version
  • 1.4.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.