Opensea <= 1.0.2 - Cross-Site Scripting

5.5
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1228
CVSS 5.5 (Medium)
Publicly Published April 10, 2022
Last Updated January 22, 2024
Researcher Mika - Patchstack Alliance

Description

The Opensea WordPress plugin before 1.0.3 does not sanitize and escape some of its settings, like its "Referer address" field, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

References

Share

1 affected software package

Software Type Plugin
Software Slug opensea (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.3, or a newer patched version
Affected Version
  • <= 1.0.2
Patched Version
  • 1.0.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation