OptinMonster <= 2.6.4 - Unprotected REST-API Endpoints

8.2
Improper Authorization
CVE CVE-2021-39341
CVSS 8.2 (High)
Publicly Published November 1, 2021
Last Updated February 3, 2023
Researcher Chloe Chamberland - Wordfence

Description

The OptinMonster WordPress plugin is vulnerable to sensitive information disclosure and unauthorized setting updates due to insufficient authorization validation via the logged_in_or_has_api_key function in the ~/OMAPI/RestApi.php file that can used to exploit inject malicious web scripts on sites with the plugin installed. This affects versions up to, and including, 2.6.4.

Wordfence blocked 18,244 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for Popup Builder by OptinMonster – WordPress Popups for Optins, Email Newsletters and Lead Generation

Software Type Plugin
Software Slug optinmonster (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.5, or a newer patched version
Affected Version
  • <= 2.6.4
Patched Version
  • 2.6.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation