OptinMonster <= 2.6.4 - Unprotected REST-API Endpoints

Improper Authorization
CVE CVE-2021-39341
CVSS 8.2 (High)
Publicly Published November 1, 2021
Last Updated February 3, 2023
Researcher Chloe Chamberland - Wordfence


The OptinMonster WordPress plugin is vulnerable to sensitive information disclosure and unauthorized setting updates due to insufficient authorization validation via the logged_in_or_has_api_key function in the ~/OMAPI/RestApi.php file that can used to exploit inject malicious web scripts on sites with the plugin installed. This affects versions up to, and including, 2.6.4.

Wordfence blocked 19,058 attacks targeting this vulnerability in the past 24 hours.



1 affected software package

Software Type Plugin
Software Slug optinmonster (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.5, or a newer patched version
Affected Version
  • <= 2.6.4
Patched Version
  • 2.6.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.