Order Export & Order Import for WooCommerce <= 2.4.9 - Authenticated (Administrator+) PHP Object Injection

Deserialization of Untrusted Data
CVE CVE-2024-34751
CVSS 7.2 (High)
Publicly Published May 14, 2024
Last Updated May 20, 2024
Researcher Trinh Vu (Sonicrrrr) - VNPT Cyber Immunity Center


The Order Export & Order Import for WooCommerce plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.4.9 via deserialization of untrusted input. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.



Vulnerability Details for Order Export & Order Import for WooCommerce

Software Type Plugin
Software Slug order-import-export-for-woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.5.0, or a newer patched version
Affected Version
  • <= 2.4.9
Patched Version
  • 2.5.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.