OWM Weather <= 5.6.11 - Cross-Site Request Forgery

8.8
Cross-Site Request Forgery (CSRF)
CVE CVE-2022-47179
CVSS 8.8 (High)
Publicly Published December 12, 2022
Last Updated February 16, 2023
Researcher Cat

Description

The OWM Weather plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.6.11. This is due to missing or incorrect nonce validation on the owmw_duplicate_post_as_draft function. This makes it possible for unauthenticated attackers to duplicate posts, via forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug owm-weather (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.6.12, or a newer patched version
Affected Version
  • <= 5.6.11
Patched Version
  • 5.6.12

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation