Page Builder: Pagelayer <= 1.7.7 - Authenticated (Author+) Stored Cross-Site Scripting via Header/Footer

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-5087
CVSS 6.4 (Medium)
Publicly Published September 25, 2023
Last Updated January 22, 2024
Researcher Marc-Alexandre Montpas


The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via header/footer post content in all versions up to, and including, 1.7.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Page Builder: Pagelayer – Drag and Drop website builder

Software Type Plugin
Software Slug pagelayer (view on
Patched? Yes
Remediation Update to version 1.7.8, or a newer patched version
Affected Version
  • <= 1.7.7
Patched Version
  • 1.7.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.