Page Builder: Pagelayer – Drag and Drop website builder <= 1.7.6 - Missing Authorization to Stored Cross-Site Scripting

Missing Authorization
CVE CVE-2023-4687
CVSS 7.2 (High)
Publicly Published September 25, 2023
Last Updated January 22, 2024
Researcher Marc-Alexandre Montpas


The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the pagelayer_save_post() function in all versions up to, and including, 1.7.6. This makes it possible for unauthenticated attackers to inject malicious JavaScript in the header/footer of scheduled posts which may execute whenever a user accesses the injected page/post.



Vulnerability Details for Page Builder: Pagelayer – Drag and Drop website builder

Software Type Plugin
Software Slug pagelayer (view on
Patched? Yes
Remediation Update to version 1.7.7, or a newer patched version
Affected Version
  • <= 1.7.6
Patched Version
  • 1.7.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.