Pardakht Delkhah <= 2.9.2 - Unauthenticated Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-4307
CVSS 7.2 (High)
Publicly Published December 27, 2022
Last Updated January 21, 2023
Researcher cydave


The Pardakht Delkhah plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'submitted_name' parameter in versions up to, and including, 2.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page



Vulnerability Details for پلاگین پرداخت دلخواه

Software Type Plugin
Software Slug pardakht-delkhah (view on
Patched? Yes
Remediation Update to version 2.9.3, or a newer patched version
Affected Version
  • <= 2.9.2
Patched Version
  • 2.9.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.