PPWP – Password Protect Pages <= 1.8.9 - Protection Mechanism Bypass

Information Exposure
CVE CVE-2024-0620
CVSS 5.3 (Medium)
Publicly Published February 7, 2024
Last Updated February 20, 2024
Researcher Francesco Carlucci


The PPWP – Password Protect Pages plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.8.9 via API. This makes it possible for unauthenticated attackers to obtain post titles, IDs, slugs as well as other information including for password-protected posts.



Vulnerability Details for PPWP – Password Protect Pages

Software Type Plugin
Software Slug password-protect-page (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.9.0, or a newer patched version
Affected Version
  • <= 1.8.9
Patched Version
  • 1.9.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.