Password Protected <= 2.6.6 - Authenticated (Admin+) Stored Cross-Site Scripting

4.4
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
CVE CVE-2024-0656
CVSS 4.4 (Medium)
Publicly Published February 19, 2024
Last Updated February 20, 2024
Researcher Felipe Restrepo Rodriguez (pfelilpe) - Pfelilpe

Description

The Password Protected – Ultimate Plugin to Password Protect Your WordPress Content with Ease plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Google Captcha Site Key in all versions up to, and including, 2.6.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

References

Share

Vulnerability Details for Password Protected – Ultimate Plugin to Protect WordPress Site, Pages & WooCommerce Store

Software Type Plugin
Software Slug password-protected (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.7, or a newer patched version
Affected Version
  • <= 2.6.6
Patched Version
  • 2.6.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation