Patreon WordPress <= 1.6.9 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2021-24230
CVSS 8.1 (High)
Publicly Published March 26, 2021
Last Updated January 22, 2024
Researchers Jetpack Scan team
George Stephanis
Benedict Singer
Miguel Neto
Fioravante Souza
Marc-Alexandre Montpas


The Patreon WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.6.9. If exploited, this bug can be used to overwrite the “wp_capabilities” meta, which contains the affected user account’s roles and privileges. Doing this would essentially lock them out of the site, blocking them from accessing paid content. This makes it possible for unauthenticated attackers to make a logged in user overwrite or create arbitrary user metadata on the victim’s account once visited via forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug patreon-connect (view on
Patched? Yes
Remediation Update to version 1.7.0, or a newer patched version
Affected Version
  • < 1.7.0
Patched Version
  • 1.7.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.