Patreon WordPress <= 1.8.1 - Authenticated Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-25026
CVSS 5.5 (Medium)
Publicly Published February 20, 2022
Last Updated January 22, 2024
Researcher José Aguilera


The Patreon WordPress plugin for WordPress is vulnerable to Cross-Site Scripting in versions up to, and including, 1.8.1 due to insufficient privilege handling. This makes it possible for high-privilege users attackers to inject arbitrary web scripts that execute in a victim's browser even when the unfiltered_html capability is disallowed.



Vulnerability Details for Patreon WordPress

Software Type Plugin
Software Slug patreon-connect (view on
Patched? Yes
Remediation Update to version 1.8.2, or a newer patched version
Affected Version
  • < 1.8.2
Patched Version
  • 1.8.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.