CodeBard's Patron Button and Widgets for Patreon <= 2.1.9 - Reflected Cross-Site Scripting via cb_p6_tab

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-47524
CVSS 6.1 (Medium)
Publicly Published November 7, 2023
Last Updated November 24, 2023
Researcher Le Ngoc Anh


The CodeBard's Patron Button and Widgets for Patreon plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘cb_p6_tab’ parameter in versions up to, and including, 2.1.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug patron-button-and-widgets-by-codebard (view on
Patched? Yes
Remediation Update to version 2.2.0, or a newer patched version
Affected Version
  • <= 2.1.9
Patched Version
  • 2.2.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.