Stripe Payment Plugin for WooCommerce <= 3.7.7 - Authentication Bypass

Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2023-3162
CVSS 9.8 (Critical)
Publicly Published August 1, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The Stripe Payment Plugin for WooCommerce plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.7.7. This is due to insufficient verification on the user being supplied during a Stripe checkout through the plugin. This allows unauthenticated attackers to log in as users who have orders, who are typically customers.



Vulnerability Details for Stripe Payment Plugin for WooCommerce

Software Type Plugin
Software Slug payment-gateway-stripe-and-woocommerce-integration (view on
Patched? Yes
Remediation Update to version 3.7.8, or a newer patched version
Affected Version
  • <= 3.7.7
Patched Version
  • 3.7.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.