Stripe Payment Plugin for WooCommerce <= 3.7.9 - Missing Authorization to Arbitrary Order Status Modification

Missing Authorization
CVE CVE-2023-4040
CVSS 5.3 (Medium)
Publicly Published August 17, 2023
Last Updated January 22, 2024
Researcher Francesco Carlucci


The Stripe Payment Plugin for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the eh_callback_handler function in versions up to, and including, 3.7.9. This makes it possible for unauthenticated attackers to modify the order status of arbitrary WooCommerce orders.



Vulnerability Details for Stripe Payment Plugin for WooCommerce

Software Type Plugin
Software Slug payment-gateway-stripe-and-woocommerce-integration (view on
Patched? Yes
Remediation Update to version 3.8.0, or a newer patched version
Affected Version
  • 3.7.9 - 3.7.9
Patched Version
  • 3.8.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.