Paytm Payment Gateway <= 2.7.0 - Unauthenticated Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2022-45362
CVSS 7.2 (High)
Publicly Published November 29, 2022
Last Updated December 15, 2022
Researcher Aman Rawat


The Paytm Payment Gateway plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 2.7.0. This is due to Server-Side Request Forgery. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



1 affected software package

Software Type Plugin
Software Slug paytm-payments (view on
Patched? Yes
Remediation Update to version 2.7.3, or a newer patched version
Affected Version
  • <= 2.7.0
Patched Version
  • 2.7.3

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.