PeproDev CF7 Database <= 1.8.0 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-41864
CVSS 4.3 (Medium)
Publicly Published April 16, 2024
Last Updated May 15, 2024
Researcher Vladislav Pokrovsky (ΞX.MI) - Independent AppSec Researcher

Description

The PeproDev CF7 Database plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.8.0. This is due to missing or incorrect nonce validation on an unknown function. This makes it possible for unauthenticated attackers to perform an unknown action granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

Vulnerability Details for PeproDev CF7 Database

Software Type Plugin
Software Slug pepro-cf7-database (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.9.0, or a newer patched version
Affected Version
  • <= 1.8.0
Patched Version
  • 1.9.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation