PeproDev Ultimate Invoice <= 1.9.7 - Unauthenticated Sensitive Information Exposure via init_plugin

Information Exposure
CVE CVE-2024-25933
CVSS 7.5 (High)
Publicly Published February 20, 2024
Last Updated April 3, 2024
Researcher Abdi Pranata


The PeproDev Ultimate Invoice plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.9.7 via the 'init_plugin' function. This makes it possible for unauthenticated attackers to generate PDF or ZIP files of arbitrary invoices and extract sensitive data.



Vulnerability Details for PeproDev Ultimate Invoice

Software Type Plugin
Software Slug pepro-ultimate-invoice (view on
Patched? Yes
Remediation Update to version 1.9.8, or a newer patched version
Affected Version
  • <= 1.9.7
Patched Version
  • 1.9.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.