Plausible Analytics <= 1.2.2 - Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-27845
CVSS 4.8 (Medium)
Publicly Published April 7, 2022
Last Updated August 29, 2022
Researcher José Aguilera


Authenticated (admin or higher user role) Stored Cross-Site Scripting (XSS) in PlausibleHQ Plausible Analytics (WordPress plugin) <= 1.2.2



Vulnerability Details for Plausible Analytics

Software Type Plugin
Software Slug plausible-analytics (view on
Patched? Yes
Remediation Update to version 1.2.3, or a newer patched version
Affected Version
  • <= 1.2.2
Patched Version
  • 1.2.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.