Plugins List <= 2.5 - Authenticated (Author+) Stored Cross-Site Scripting via replace_plugin_list_tags

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-31232
CVSS 6.4 (Medium)
Publicly Published April 28, 2023
Last Updated January 22, 2024
Researcher Yuki Haruma - Tokyo Denki University, Faculty of Engineering, Department of Information and Communication Engineering, Cryptography Laboratory


The Plugins List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the replace_plugin_list_tags function in versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with author-level access or higher to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Plugins List

Software Type Plugin
Software Slug plugins-list (view on
Patched? Yes
Remediation Update to version 2.5.1, or a newer patched version
Affected Version
  • <= 2.5
Patched Version
  • 2.5.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.