Paid Memberships Pro - Courses for Membership Add On <= 1.2.3 - Cross-Site Request Forgery to Course Modifications

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published August 8, 2023
Last Updated August 8, 2023


The Paid Memberships Pro - Courses for Membership Add On plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce verification on the pmpro_courses_update_course_callback() and pmpro_courses_remove_course_callback() functions called via AJAX actions in versions up to, and including, 1.2.3. This makes it possible for unauthenticated attackers to update and remove courses from the course page via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug pmpro-courses (view on
Patched? Yes
Remediation Update to version 1.2.4, or a newer patched version
Affected Version
  • < 1.2.4
Patched Version
  • 1.2.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.