Podlove Podcast Publisher <= 4.0.11 - Authenticated (Contributor+) Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2024-32812
CVSS 4.3 (Medium)
Publicly Published April 22, 2024
Last Updated April 30, 2024
Researcher Majed Refaea


The Podlove Podcast Publisher plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 4.0.11 via the fetch_url_meta function. This makes it possible for authenticated attackers, with contributor-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



Vulnerability Details for Podlove Podcast Publisher

Software Type Plugin
Software Slug podlove-podcasting-plugin-for-wordpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.12, or a newer patched version
Affected Version
  • <= 4.0.11
Patched Version
  • 4.0.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.