Poll Maker <= 3.2.8 – Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-34635
CVSS 6.1 (Medium)
Publicly Published July 26, 2021
Last Updated January 22, 2024
Researcher Xu-Liang Liao


The Poll Maker WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the mcount parameter found in the ~/admin/partials/settings/poll-maker-settings.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 3.2.8.



Vulnerability Details for Poll Maker – Versus Polls, Anonymous Polls, Image Polls

Software Type Plugin
Software Slug poll-maker (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.2.9, or a newer patched version
Affected Version
  • <= 3.2.8
Patched Version
  • 3.2.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.