Poll Maker <= 4.8.0 - Missing Authorization

Missing Authorization
CVE CVE-2023-50904
CVSS 5.3 (Medium)
Publicly Published December 26, 2023
Last Updated January 22, 2024
Researcher Abdi Pranata


The Poll Maker plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on an unknown function in versions up to, and including, 4.8.0. This makes it possible for unauthenticated attackers to perform unauthorized actions.



Vulnerability Details for Poll Maker – Versus Polls, Anonymous Polls, Image Polls

Software Type Plugin
Software Slug poll-maker (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.8.1, or a newer patched version
Affected Version
  • <= 4.8.0
Patched Version
  • 4.8.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.