Pop-up <= 1.1.1 - Missing authorization to Settings Change

Missing Authorization
CVSS 7.1 (High)
Publicly Published August 8, 2022
Last Updated November 24, 2022


The Pop-up plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the function wp_ajax_wp_mypopups in versions up to, and including, 1.1.1. This makes it possible for authenticated attackers to change the plugin's settings.



Vulnerability Details for Pop-up

Software Type Plugin
Software Slug pop-up-pop-up (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.1.2, or a newer patched version
Affected Version
  • <= 1.1.1
Patched Version
  • 1.1.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.