Popup Builder <= 3.63 - Authenticated Settings Modification, Configuration Disclosure, and User Data Export

Information Exposure
CVE CVE-2020-10195
CVSS 6.3 (Medium)
Publicly Published March 12, 2020
Last Updated December 19, 2022
Researcher Ram - Wordfence


The Popup Builder plugin before 3.64.1 for WordPress allows information disclosure and settings modification, leading to in-scope privilege escalation via admin-post actions to com/classes/Actions.php. By sending a POST request to wp-admin/admin-post.php, an authenticated attacker with minimal (subscriber-level) permissions can modify the plugin's settings to allow arbitrary roles (including subscribers) access to plugin functionality by setting the action parameter to sgpbSaveSettings, export a list of current newsletter subscribers by setting the action parameter to csv_file, or obtain system configuration information including webserver configuration and a list of installed plugins by setting the action parameter to sgpb_system_info.

Wordfence blocked 4 attacks targeting this vulnerability in the past 24 hours.



Vulnerability Details for Popup Builder – Create highly converting, mobile friendly marketing popups.

Software Type Plugin
Software Slug popup-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.64.1, or a newer patched version
Affected Version
  • <= 3.63
Patched Version
  • 3.64.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.