Popup Builder <= 3.72 Missing Authorization on AJAX actions

Missing Authorization
CVSS 6.3 (Medium)
Publicly Published January 28, 2021
Last Updated January 22, 2024
Researcher Patchstack - Patchstack


The Popup Builder plugin for WordPress is vulnerable to authorization bypass in versions up to, and including 3.71 due to missing capability checks on various actions called via AJAX. This makes it possible for attackers to import subscribers and send newsletters among other actions.



Vulnerability Details for Popup Builder – Create highly converting, mobile friendly marketing popups.

Software Type Plugin
Software Slug popup-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.72, or a newer patched version
Affected Version
  • <= 3.71
Patched Version
  • 3.72

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.