Popup Builder <= 4.0.6 - Authenticated SQL Injection via order & orderby Parameters

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2022-0228
CVSS 7.2 (High)
Publicly Published January 24, 2022
Last Updated January 22, 2024
Researcher Tony Wu


The Popup Builder WordPress plugin before 4.0.7 does not validate and properly escape the orderby and order parameters before using them in a SQL statement in the admin dashboard, which could allow high privilege users to perform SQL injection



Vulnerability Details for Popup Builder – Create highly converting, mobile friendly marketing popups.

Software Type Plugin
Software Slug popup-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.7, or a newer patched version
Affected Version
  • < 4.0.7
Patched Version
  • 4.0.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.