Popup Builder <= 4.0.6 - Local File Inclusion and PHAR Deserialization

8.8
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')
CVE CVE-2021-25082
CVSS 8.8 (High)
Publicly Published January 24, 2022
Last Updated December 19, 2022
Researcher ZhongFu Su

Description

The Popup Builder WordPress plugin before 4.0.7 does not validate and sanitise the sgpb_type parameter before using it in a require statement, leading to a Local File Inclusion issue. Furthermore, since the beginning of the string can be controlled, the issue can lead to RCE vulnerability via wrappers such as PHAR

Wordfence blocked 15 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for Popup Builder – Create highly converting, mobile friendly marketing popups.

Software Type Plugin
Software Slug popup-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.7, or a newer patched version
Affected Version
  • < 4.0.7
Patched Version
  • 4.0.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation