Popup Builder <= 4.3.0 - Missing Authorization in Multiple AJAX Actions

Missing Authorization
CVE CVE-2024-2544
CVSS 7.4 (High)
Publicly Published June 14, 2024
Last Updated June 15, 2024
Researcher Alex Thomas - Wordfence


The Popup Builder plugin for WordPress is vulnerable to unauthorized modification of data and loss of data due to a missing capability check on all AJAX actions. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform multiple unauthorized actions, such as deleting subscribers, and importing subscribers to conduct stored cross-site scripting attacks.



Vulnerability Details for Popup Builder – Create highly converting, mobile friendly marketing popups.

Software Type Plugin
Software Slug popup-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.3.2, or a newer patched version
Affected Version
  • <= 4.3.0
Patched Version
  • 4.3.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.