Popup More <= 2.2.4 - Authenticated (Admin+) Directory Traversal to Limited Local File Inclusion

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2024-0844
CVSS 4.7 (Medium)
Publicly Published February 1, 2024
Last Updated February 9, 2024
Researcher 0x9567b


The Popup More Popups, Lightboxes, and more popup modules plugin for WordPress is vulnerable to Local File Inclusion in version 2.1.6 via the ycfChangeElementData() function. This makes it possible for authenticated attackers, with administrator-level access and above, to include and execute arbitrary files ending with "Form.php" on the server , allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.



Vulnerability Details for Popup – Popup More Popups

Software Type Plugin
Software Slug popup-more (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.5, or a newer patched version
Affected Version
  • 2.1.6 - 2.1.6
Patched Version
  • 2.2.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.