Post Meta Data Manager <=1.2.0 - Missing Authorization to User, Term, and Post Meta Deletion

Missing Authorization
CVE CVE-2023-5426
CVSS 7.5 (High)
Publicly Published October 27, 2023
Last Updated October 28, 2023
Researcher Francesco Carlucci


The Post Meta Data Manager plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the pmdm_wp_delete_user_meta, pmdm_wp_delete_term_meta, and pmdm_wp_ajax_delete_meta functions in versions up to, and including, 1.2.0. This makes it possible for unauthenticated attackers to delete user, term, and post meta belonging to arbitrary users.



1 affected software package

Software Type Plugin
Software Slug post-meta-data-manager (view on
Patched? Yes
Remediation Update to version 1.2.1, or a newer patched version
Affected Version
  • <= 1.2.0
Patched Version
  • 1.2.1

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.