Post SMTP <= 2.1.6 - Authenticated (Administrator+) Blind Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2022-2352
CVSS 6.6 (Medium)
Publicly Published September 5, 2022
Last Updated January 22, 2024
Researcher Raad Haddad


The Post SMTP plugin for WordPress is vulnerable to blind Server-Side Request Forgery. This is due to improper authorization on some of the plugin's AJAX actions.



Vulnerability Details for Post SMTP – WordPress SMTP Plugin with Email Logs and Mobile App for Failure Notifications – Gmail SMTP, Office 365, Brevo, Mailgun, Amazon SES and more

Software Type Plugin
Software Slug post-smtp (view on
Patched? Yes
Remediation Update to version 2.1.7, or a newer patched version
Affected Version
  • <= 2.1.6
Patched Version
  • 2.1.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.