POST SMTP Mailer <= 2.0.20 - Cross-Site Request Forgery Bypass

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2021-4422
CVSS 4.3 (Medium)
Publicly Published March 1, 2021
Last Updated January 22, 2024
Researcher Jerome Bruandet - NinTechNet

Description

The POST SMTP Mailer plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.0.20. This is due to missing or incorrect nonce validation on the handleCsvExport() function. This makes it possible for unauthenticated attackers to trigger a CSV export via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Post SMTP – WP SMTP Plugin with Email Logs & Mobile App for Failure Alerts – Any SMTP Plus Gmail SMTP, Office 365, Brevo, Mailgun, Amazon SES, Postmark

Software Type Plugin
Software Slug post-smtp (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.0.21, or a newer patched version
Affected Version
  • <= 2.0.20
Patched Version
  • 2.0.21

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation